Выбор определенной версии php на хостинге — Онлайн-форум, версия php на хостинге.

Версия php на хостинге

Настоящие Правила Раздела являются дополннением к Общим Правилам Конференции. В случаях противоречий отдельных пунктов, действуют Правила Раздела.

Запрещается

  1. Обсуждение хостинговых компаний и качества предоставляемых ими услуг.
  2. Реклама и антиреклама услуг хостинговых компаний.
  3. Навязывание собственных услуг в любом виде.

Участникам Клуба хостинг-провайдеров разрешено давать ссылки на профайл своей компании в каталоге хостинга только в случае явного запроса услуг потенциальным клиентом. При поиске автором темы уникальных или специфических услуг, не описанных в каталоге хостинга, допускается информирование клиента о предоставлении таковых только персонально в личных сообщениях или с использованием другой контактной информации из профайла автора темы.

Группа: Старые пользователи

— Разговаривая с техподдержкой одного из хостеров, получил информацию, что при поддержке возможности установки собственного php.ini тарифом, можно разместить свой php.ini от версии 5.2, например, и не иметь головной боли с будущими апдейтами. Так ли это, или все же надо искать хостинг, который предоставит площадку именно с 5.2?

— Есть ли более-менее известные хостеры, у которых можно выбрать версию php именно 5.2 с сохранением ее в обозримом будущем? (гуляя по сайтам хостов видел выбор только между головными 4 и 5-версиями)

Группа: Старые пользователи

Общий ответ — ничего не спасёт. ветка php 5.2 уже брошена разработчиками и умрёт точно также, как и все предыдущие. Поэтому ищите возможность у хостера самому собирать нужную php и использовать её, либо VDS, и если проект большой — то выделенный сервер.

Группа: Старые пользователи

Из: Хостинг-оператор eServer.ru

Вы не в том разделе запрос создали для поиска услуг.

Да нет же, Петр, нормальное место выбрано, т.к. это не столько поиск услуг, сколько предложение саму проблему проанализировать. А она есть и весьма больная для многих клиентов и интересна по сути своей даже мне, с моим отдельным сервером.

Согласно п.3 правил этого раздела, при явном запросе автором темы напоминать о своем существовании всё-таки можно. Поэтому было бы интересно здесь прочитать кто какой политики придерживается в отношении нового ПО для старых клиентов.

Группа: Старые пользователи

5.2.* — был есть и еще долго будет.

5.3.* — пока в планах и только по запросу для новых клиентов.

Группа: Старые пользователи

. Было принято решение подыскать виртуалку с php5.2, а обновляться когда-нибудь потом. При этом хотелось бы обезопасить проект от "внезапного" обновления версии php, чтобы потом опять срочно не бежать куда-то, сломя голову.

Абсолютно правильное решение — на VDSe вы сами хозяин, что хотите, ставите. и никто вам не запретит держать старое ПО, которое устраивает именно вас..

Единственный минус от шаред хостинга — требуется изначальная настройка, но подозреваю вас она не пугает.

Группа: Старые пользователи

сколько предложение саму проблему проанализировать.

Пётр, у Вас все смешанно получилось, поэтому я не понял — Вы проблему клиента или проблему его хостера обсуждаете?

я ТС ответил в плане решения возникшей ситуации и специально добавил "общий". Конкретные ситуации у конкректных хостеров достаточно специфичны, так как хостеры не занимаются разработкой интерпретатора php

Если говорить про конкретные ситуации, то мы, при апгрейде на php5 всех клиентов, у которых скрипты не дружат с пятёркой оставили на сервере с php4

5.2.* — был есть и еще долго будет.

To prepare for upgrading to PHP 5.3, now that PHP 5.2's support ended

Думаю, что будь судебная система у нас по-проще, rounder с блеском бы выиграл процесс против хостера за предоставление таких услуг за его деньги.

Если он услуги купил действительно у хостера, а не человека-компании, так как ни один хостер в здравом уме не будет без предупреждения менять мажорную цифру версии интерпретатора.

У нас еще даже PHP 4.4 жива.

у нас она тоже есть, но закрыта для приёма новых заказов.

Пётр, у Вас все смешанно получилось, поэтому я не понял — Вы проблему клиента или проблему его хостера обсуждаете?

Хм. на этот раз не понял я (IMG:style_emoticons/default/smile.gif). Мне они как-то очень взаимосвязаными представляются. Проблема хостера стала проблемой клиента. Если решить проблему хостера, проблема клиента сама собой отвалится. Как решить проблему этого конкретного клиента, более-менее понятно — сменить хостера, или перенести сайт на VDS, или на выденный сервер. А как решить проблему таких хостеров, которые заманивают разными сладкими морковками, а потом издеваются над клиентами — я не знаю.

Группа: Старые пользователи

Из: Хостинг-оператор eServer.ru

у нас она тоже есть, но закрыта для приёма новых заказов.

У нас выбор версии на каждом суб-домене имеется, поэтому клиент может выбрать 4,5.2,5.3 версию

кол-во версий будем расширять

Группа: Старые пользователи

Попробую разбить на части:

1. время не властно над истинными ценностями, но программное обеспечение к таковым, увы, практически не отнести. Покупая хостинг у хостера вы покупаете своего рода новую машину, на которой ваш сайт продолжит движение: стремительное или не медленное, как поступь черепахи. Комфортное, с подогревом сидений зимой и кондиционером летом или эконом класса, когда коленки прижаты к ушам. Как часто будет ваша машина ломаться (а может и не будет) или есть ли в ней какие-то дефекты производства вы перед покупкой, с большой долей вероятности, можете узнать заранее. Информации для этого предостаточно. Но, иногда, мы сами себя начинаем обманывать и делаем несознательный выбор в покупке и в дальнейшем за это расплачиваемся, при этом героически преодолеваем все препятствия и при новом выборе хостера. опять наступаем на те же самые грабли. Здесь подробно показано как такие трагедии превращаются в фарс

Возникшая проблема номер 1 — "когда я покупал у вас хостинг у меня всё работало. я ничего не менял, но сейчас у меня превышение нагрузки/тормозит/медленно работает.." и дальше идёт перечисление ещё 33 несчастий владельца сайта.

Думаю, что будь судебная система у нас по-проще, Admin с блеском бы выиграл процесс против ЗАЗ за вечный ремонт Запорожца за его деньги.

Развитые страны стимулирует такое "омоложение" повышений налогов на машины старше 3-5 лет. Развивающиеся страны, пытаясь попутно поддержать отечественный автопром и прикрыть этот поток "утиля" из развитых стран — повышают импортные пошлины на старые машины и делают благоприятные условия для запуска новых производств на своей территории (опустим за кадром обсуждение, что этот "импортный утиль" зачастую превышает по качеству наш отечественный автопром).

А если у хостера открыт приём заказ на старые версии? Да, это решает проблему клиента — он находит нужную запчасть и машина его едет дальше.

Это со стороны клиента. Теперь смотрим на проблему со стороны хостера. Например, на общем сервере у хостера открыт к приёму старых версий , а в них, с большой уверенностью можно сказать, обнаружено много уязвимостей, которые разработчики уже не патчат и это создаёт дополнительный риск возникновения неблагоприятных ситуаций на сервере. Например, взлом аккаунта клиента и возникает извечный вопрос "кто виновать и что делать?".

Приходит день, когда Вы понимаете, что вкладываете в ремонт старой машины больше, чем в случае, если бы купили новую.

Группа: Старые пользователи

Заодно, составил себе небольшой списочек хостеров с мягкой политикой обновления из отписавшихся здесь.