Хостинг HostYes, Часто задаваемые вопросы, версии PHP, поддержка и выбор PHP 5, версия php на хостинге.

Версия php на хостинге

Информация, указанная ниже актуальна для аккунтов, размещенных в России. Информация о работе с PHP для аккаунтов, размещенных в Германии здесь

PHP — язык программирования общего назначения, применяемый для разработки веб-приложений. В настоящее время является одним из лидеров среди языков программирования для построения динамических веб приложений.

Версия PHP 5.3 включена по умолчанию при активации аккаунта. В любой момент вы можете переключить PHP на версии 5.2 5.3 5.4 или 5.5

Отличия и руководство по миграции для версий PHP 5.2.x, 5.3.x, 5.4.x и 5.5.x.

Обратите внимание, в рамках одного аккаунта невозможно использовать одновременно несколько версии PHP

Для переключения версий php перейдите в меню «Выбор версии php» в модуле «World Wide Web». Для выбора выделите нужную версию и нажмите «Выбрать»

В разделе «Модули» доступна активация или декативации дополнительных модулей php

В разделе «php.ini» можно изменить некоторые настройки интерпретатора. Настройки применяются только к той версии в разделе которой они изменены. Если требуется изменения других настроек обратитесь в техническую поддержку. Также вы можете прислать готовый php.ini, который будет установлен для вашего аккаунта.

Так, например, для работы 1С-Битрикс следует добавить следуюшие настройки: mbstring.func_overload=2 mbstring.internal_encoding=utf-8

Для этого выделите требуемую версию php и нажмите «php.ini», двойным кликом мыши вызовите диалоговое окно с доступными значениями, установите «2» и нажмите ОК

Выполните аналогичную операцию для изменения mbstring.internal_encoding

PHP Акселераторы

eAccelerator уже подключен и активирован для всех версий кроме 5.5. eAccelerator показал хорошую производительность и стабильность работы на виртуальном хостинге. Рекомендуется использовать его для кеширования исходного кода. Для версии php 5.5 доступен акселератор Zend OPcache. Вы можете активировать его в контрольной панели.

Декодирование исходного кода

Для запуска закодированных скриптов на хостинге установлены и активированы ionCube Loader, Zend Guard или Zend Optimizer